User Tools

Site Tools


Command disabled: revisions
photo:diy_noaperture

troubleshooting: camera not displaying lens aperture

The Problem

  • digital camera with interchangeable lens system does not display an aperture reading, and in some cases this also results in failure of the camera to fire
  • this is caused by loss of electronic connection between the camera and lens
  • obviously, if the lens does not have electronic contacts or is not designed for the camera and you are using a mount adapter that does not transfer the electronic signal then the camera will not be able to detect the lens aperture
    • some cameras (especially Panasonic will not fire the shutter in this situation unless you change the default menu item such as “Shoot Without Lens” to Yes.
  • for other lenses, the issue is a problem with the contacts

How to fix this

  • re-mount the lens
    • sometimes a slight mismatch in contact position may prevent proper contact
  • turn camera off and then on
    • occasionally the camera's algorithm can get confused and “rebooting” the camera may fix it
  • clean the contacts of both lens and camera
    • take care not to contaminate the sensor
  • ensure lens mount is not loose
    • tighten the screws of the lens mount on the camera and the lens to ensure there is no play which would otherwise cause the lens contacts to separate from the camera contacts
  • if all fails then take camera or lens to repairs
    • try to determine which is at fault, the camera or the lens by trying different lenses and cameras
photo/diy_noaperture.txt · Last modified: 2017/10/07 07:52 by gary1